<!DOCTYPE html>
<html lang="en">

<head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <title>Wallet Security: The &#039;Non-Custodial&#039; Fallacy - a16z crypto</title>
    
    <link rel="preconnect" href="https://fonts.googleapis.com">
    <link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
    <link href="https://fonts.googleapis.com/css2?family=Arvo:ital,wght@0,400;0,700;1,400;1,700&display=swap" rel="stylesheet">
    
        
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.6 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="When it comes to &quot;non-custodial&quot; wallet security, you may think your crypto keys are yours... but are they really?" />
	<link rel="canonical" href="https://a16zcrypto.com/wallet-security-non-custodial-fallacy/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Wallet Security: The &#8216;Non-Custodial&#8217; Fallacy" />
	<meta property="og:description" content="When it comes to &quot;non-custodial&quot; wallet security, you may think your crypto keys are yours... but are they really?" />
	<meta property="og:url" content="https://a16zcrypto.com/wallet-security-non-custodial-fallacy/" />
	<meta property="og:site_name" content="a16z crypto" />
	<meta property="article:published_time" content="2022-10-14T10:40:36+00:00" />
	<meta property="article:modified_time" content="2022-10-14T14:39:26+00:00" />
	<meta property="og:image" content="https://a16zcrypto.com/wp-content/uploads/2022/10/Non-Custodial-Wallet_FB.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="630" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:image" content="https://a16zcrypto.com/wp-content/uploads/2022/10/Non-Custodial-Wallet_TW.jpg" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Nassim Eddequiouaq and Riyaz Faizullabhoy" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="17 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://a16zcrypto.com/#organization","name":"a16z crypto","url":"https://a16zcrypto.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://a16zcrypto.com/#logo","inLanguage":"en-US","url":"https://a16zcrypto.com/wp-content/uploads/2022/04/a16z-crypto-Logo-lc_Solid.png","contentUrl":"https://a16zcrypto.com/wp-content/uploads/2022/04/a16z-crypto-Logo-lc_Solid.png","width":1301,"height":701,"caption":"a16z crypto"},"image":{"@id":"https://a16zcrypto.com/#logo"}},{"@type":"WebSite","@id":"https://a16zcrypto.com/#website","url":"https://a16zcrypto.com/","name":"a16z crypto","description":"a16z crypto","publisher":{"@id":"https://a16zcrypto.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://a16zcrypto.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#primaryimage","inLanguage":"en-US","url":"https://a16zcrypto.com/wp-content/uploads/2022/10/Non-Custodial-Wallet_FB.jpg","contentUrl":"https://a16zcrypto.com/wp-content/uploads/2022/10/Non-Custodial-Wallet_FB.jpg","width":1200,"height":630},{"@type":"WebPage","@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#webpage","url":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/","name":"Wallet Security: The 'Non-Custodial' Fallacy - a16z crypto","isPartOf":{"@id":"https://a16zcrypto.com/#website"},"primaryImageOfPage":{"@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#primaryimage"},"datePublished":"2022-10-14T10:40:36+00:00","dateModified":"2022-10-14T14:39:26+00:00","description":"When it comes to \"non-custodial\" wallet security, you may think your crypto keys are yours... but are they really?","breadcrumb":{"@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://a16zcrypto.com/wallet-security-non-custodial-fallacy/"]}]},{"@type":"BreadcrumbList","@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://a16zcrypto.com/"},{"@type":"ListItem","position":2,"name":"Wallet Security: The &#8216;Non-Custodial&#8217; Fallacy"}]},{"@type":"Article","@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#article","isPartOf":{"@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#webpage"},"author":{"@id":"https://a16zcrypto.com/#/schema/person/187a2e73ce0da35f641fc3b9e1e6cb14"},"headline":"Wallet Security: The &#8216;Non-Custodial&#8217; Fallacy","datePublished":"2022-10-14T10:40:36+00:00","dateModified":"2022-10-14T14:39:26+00:00","mainEntityOfPage":{"@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#webpage"},"wordCount":3725,"publisher":{"@id":"https://a16zcrypto.com/#organization"},"image":{"@id":"https://a16zcrypto.com/wallet-security-non-custodial-fallacy/#primaryimage"},"thumbnailUrl":"https://a16zcrypto.com/wp-content/uploads/2022/10/Non-Custodial-Wallet_1920x1080.jpg","keywords":["a16z crypto"],"inLanguage":"en-US"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/a16zcrypto.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://a16zcrypto.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='base-theme-style-css'  href='https://a16zcrypto.com/wp-content/themes/a16z-crypto/assets/compiled/css/theme.css?id=b4212bba4f86d68da4aa' type='text/css' media='all' />
<script type='text/javascript' src='https://a16zcrypto.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://a16zcrypto.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://a16zcrypto.com/wp-json/" /><link rel="alternate" type="application/json" href="https://a16zcrypto.com/wp-json/wp/v2/posts/2253" /><link rel='shortlink' href='https://a16zcrypto.com/?p=2253' />
<link rel="alternate" type="application/json+oembed" href="https://a16zcrypto.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fa16zcrypto.com%2Fwallet-security-non-custodial-fallacy%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://a16zcrypto.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fa16zcrypto.com%2Fwallet-security-non-custodial-fallacy%2F&#038;format=xml" />
<style>
  @media (max-width: 767px) {
    .hidden-mobile {
      display:none;
    }
  }
</style><link rel='shortcut icon' href='https://a16zcrypto.com/wp-content/uploads/2022/04/a16z-crypto-Logo-lc_Solid.png' type='image/x-icon'>
<link rel="icon" href="https://a16zcrypto.com/wp-content/uploads/2022/04/cropped-a16zcrypto_favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://a16zcrypto.com/wp-content/uploads/2022/04/cropped-a16zcrypto_favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://a16zcrypto.com/wp-content/uploads/2022/04/cropped-a16zcrypto_favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://a16zcrypto.com/wp-content/uploads/2022/04/cropped-a16zcrypto_favicon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			code {
	background-color: #f6f7f7;
	border-radius: 5px;
	padding: 5px;
}		</style>
		
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=G-N97PHKHBEQ"></script>
    <script>
        window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());
        gtag('config', 'G-N97PHKHBEQ');
    </script>

    
</head><body >
    <div id="wrapper">
        <header class="header" id="header">
    <div class="container">
        <div class="logo"><a href="https://a16zcrypto.com"><img src="https://a16zcrypto.com/wp-content/themes/a16z-crypto/assets/images/logo.svg" alt="a16z Crypto"></a></div>
    </div>
</header>
        <main id="main">
    <article class="main-article">
        <div class="container">
            <div class="head">
                <h1>Wallet Security: The &#8216;Non-Custodial&#8217; Fallacy</h1>
                                                    <h2 class="h5">by Nassim Eddequiouaq and Riyaz Faizullabhoy</h2>
                                                                <div class="tag"></div>
                                <time>October 14, 2022</time>
            </div>
            <div class="content-wrapper">
                <div class="content-sidebar">
                    <div class="sticky-nav" id="toc-menu" style="display: none;">
    <div class="top">
        <a href="#" class="title">
            <span class="text-hold">
                Contents <span class="mark">:</span> <span class="current-item toc-list--mobile"></span>
            </span>
        </a>
        <ul class="toc-list--desktop"></ul>
    </div>
</div>
                </div>
                <div class="content-main">
                    <p><span style="font-weight: 400;">The commonly cited expression “not your keys, not your crypto” conveys the purist’s philosophy of cryptographic key management. In this wallet security model, only an individual (or a group via “multisig”) has direct and sole control over their own private keys – and, therefore, has true ownership of their crypto assets. Crypto wallets adhering to this hard-line approach are called “non-custodial,” meaning no outside parties have access to keys.</span></p>
<p><span style="font-weight: 400;">Except, not so fast. The situation isn’t so simple. A number of high-profile “non-custodial” wallet hacks – including the </span><a href="https://solana.com/news/8-2-2022-application-wallet-incident" target="_blank" rel="noopener"><span style="font-weight: 400;">Slope wallet hack</span></a><span style="font-weight: 400;"> that compromised more than 8,000 accounts in August, the </span><a href="https://blog.iota.org/trinity-attack-incident-part-1-summary-and-next-steps-8c7ccc4d81e8/" target="_blank" rel="noopener"><span style="font-weight: 400;">Trinity wallet hack</span></a><span style="font-weight: 400;"> that lost more than $2 million worth of IOTA tokens in 2020, the </span><a href="https://blog.openzeppelin.com/on-the-parity-wallet-multisig-hack-405a8c12e8f7/" target="_blank" rel="noopener"><span style="font-weight: 400;">Parity wallet hack</span></a><span style="font-weight: 400;"> that allowed an attacker to steal 150,000 ETH in 2017, plus discoveries of various </span><a href="https://www.wired.com/story/cryptocurrency-hardware-wallets-can-get-hacked-too/" target="_blank" rel="noopener"><span style="font-weight: 400;">hardware wallet vulnerabilities</span></a><span style="font-weight: 400;">, and other incidents – undermines the conventional distinction between custodial and non-custodial wallets. In many of these cases, victims who believed they were using a non-custodial wallet found attackers were able to hijack their coveted keys. A contradiction, no?</span></p>
<p><span style="font-weight: 400;">Indeed, the story is more complex than a catchphrase can capture. Non-custodial wallets do not really put users in full control of their keys. That’s because wallets are typically</span> <span style="font-weight: 400;">created by, and operated via,</span><i><span style="font-weight: 400;"> someone else’s software or hardware</span></i><span style="font-weight: 400;">. Users constantly put their trust in other people, products, and computer programs. They accept using blockchain command-line-interfaces, wallet software and devices, centralized platforms, </span><span style="font-weight: 400;">smart contract code, decentralized applications, and all the various wallet </span><span style="font-weight: 400;">connection integrations in between. Each touchpoint adds risk; the sum of all these interlocking parts shatters the illusion of the non-custodial wallet.</span></p>
<p><span style="font-weight: 400;">Custodianship is, in reality, </span><i><span style="font-weight: 400;">non</span></i><span style="font-weight: 400;">&#8211;</span><i><span style="font-weight: 400;">binary</span></i><span style="font-weight: 400;">. What might at first appear to be non-custodial may actually involve many custodial elements whose reliability people often take for granted. The traditional dichotomy – custodial vs. non-custodial – is a false one. </span></p>
<p><span style="font-weight: 400;">Instead, it’s better to regard wallets with more nuance. The key questions to ask are: How big an attack surface am I comfortable accepting, and how many responsibilities am I willing to take on in my quest to eliminate trust in third parties? In general, key management – the foundation of wallet security – can be divided into three areas, each of which has unique opportunities for exposure. The subcategories are as follows:</span></p>
<ol>
<li style="font-weight: 400;" aria-level="1">
<h5><span style="font-weight: 400;"><a href="#key-generation">Key generation</a> (creating cryptographic keys)</span></h5>
</li>
<li style="font-weight: 400;" aria-level="1">
<h5><span style="font-weight: 400;"><a href="#key-storage">Key storage</a> (securing keys at rest)</span></h5>
</li>
<li style="font-weight: 400;" aria-level="1">
<h5><span style="font-weight: 400;"><a href="#key-usage">Key usage</a> (putting keys to work)</span></h5>
</li>
</ol>
<p><span style="font-weight: 400;">This overview is intended to help web3 users better understand the intricacies involved in securing their assets by way of the rubric above. Further, we aim to help engineers identify and shore up frequent points of failure in wallet development. We hope that applying this guide – sourced from our many years of combined experience building crypto and security systems across Docker, Anchorage, Facebook, and a16z crypto – will help people to avoid security mishaps, whether they’re interacting with, participating in, or building web3 tech.</span></p>
<p><span style="font-weight: 400;">Below, we cover common features and pitfalls of crypto wallet security and custody platforms as they exist today. We also cover areas we believe require the most attention and development in the coming months and years to improve the safety of users’ web3 experiences.</span></p>
<h2 id="key-generation"><span style="font-weight: 400;">Key generation: wallet security</span></h2>
<p><span style="font-weight: 400;">Any discussion of wallet security must begin with key generation, the process of creating cryptographic keys. Whether the wallet is considered custodial or non-custodial, the security properties of the key generation step are paramount to the keys’ safety thereafter. During key generation, there are three overarching concerns to keep in mind: using reliable code, implementing the code properly, and safely handling the output.</span></p>
<p><span style="font-weight: 400;">If you’re not a crypto expert, it can be difficult to verify that all of the following factors are being done by the book. Check to see whether you can access a trusted audit report, which some wallet providers publish on their official websites or Github repositories. In lieu of that, </span><span style="font-weight: 400;">do your own research to try to determine whether there’s a reputable company behind the wallet. If information is sparse, significant user and developer activity might be the next indicator of reputability.</span></p>
<p><span style="font-weight: 400;">Follow these guidelines to reduce your risk exposure. If a wallet fails the below checks, run away!</span><b></b></p>
<ul>
<li aria-level="1"><b>Use wallets that don’t roll their own crypto</b></li>
</ul>
<p><span style="font-weight: 400;">Cryptographers have a saying: “don’t roll your own crypto.” The gist is similar to the adage “don’t reinvent the wheel.” The wheel is fine as is and any attempt to rebuild one from scratch is likely to result in a worse product. Same goes for crypto, a science that is hard to get exactly right. The code composing a wallet should have a reputation for working well. Choosing poorly written software – or attempting to develop one’s own alternative </span><i><span style="font-weight: 400;">de novo</span></i><span style="font-weight: 400;"> – can lead to mishaps such as key leakage or revealing secret information to unauthorized parties. This is what was behind a recently exploited vulnerability in </span><a href="https://medium.com/amber-group/exploiting-the-profanity-flaw-e986576de7ab" target="_blank" rel="noopener"><span style="font-weight: 400;">Profanity’s vanity address tool</span></a><span style="font-weight: 400;">. Before anything else, it should be clear the wallet in question uses an audited and reputable key generation library and process.</span><b></b></p>
<ul>
<li aria-level="1"><b>Use wallets that measure twice and cut again and again</b></li>
</ul>
<p><span style="font-weight: 400;">Even if the code uses reputable cryptography libraries, it still must be integrated properly. Vetted software will typically set up correct parameters by default, but there can be gaps in execution. For instance, a strong source of entropy, or dose of mathematical randomness, is required to make to-be-generated keys unpredictable and, therefore, more secure. For certain key generation processes, such as for many Multi-Party Computation (MPC) algorithms, in which many separate keys – or shards, fragments of keys – must be generated and coordinated, the wallet ought to follow the precise protocol as specified by the algorithm. The algorithm may also require multiple rounds of computation as well as refreshing keys, which the wallet must integrate properly to maintain the security of the funds.</span><b></b></p>
<ul>
<li aria-level="1"><b>Use a wallet that can keep secrets</b></li>
</ul>
<p><span style="font-weight: 400;">The final phase of the key generation process involves the actual operation and output of the software. </span><span style="font-weight: 400;">Be aware of where the keys are being generated and in what form.</span></p>
<p><span style="font-weight: 400;">Ideally, the keys should be generated in isolated hardware, and the information should be encrypted with a reputable algorithm. An example of a weak one to be avoided is Data Encryption Standard, or DES, which is today </span><a href="https://w2.eff.org/Privacy/Crypto/Crypto_misc/DESCracker/" target="_blank" rel="noopener"><span style="font-weight: 400;">considered broken</span></a><span style="font-weight: 400;">. Keys left in plaintext – especially in memory, on-disk, or in the middle-zone between those two places known as “swap” – are a major security risk. In general, key material should not leave the hardware it&#8217;s generated on and should not escape onto networks accessible by others. (That is, unless the key material is encrypted, in which case the encryption key must be secured too.)</span></p>
<p><span style="font-weight: 400;">The keys for Slope, the wallet that got hacked this summer, </span><span style="font-weight: 400;">were logged in plaintext to outside servers after being generated. This is the kind of security lapse that could have surfaced in an audit or open source implementation of the code. Wallets that lack transparency – featuring closed-source code, no available third party security audits to the public – should raise red flags. </span></p>
<h2 id="key-storage"><span style="font-weight: 400;">Key storage: wallet security</span></h2>
<p><span style="font-weight: 400;">After keys are generated, </span><span style="font-weight: 400;">they will need to be stashed somewhere – never in plaintext, always encrypted. But merely </span><span style="font-weight: 400;">owning the device on which keys are stored does not necessarily equate to key ownership and control. Many factors such as the supply chain security of the device, how connected the device is, and what other components the device interacts with must be considered. Furthermore, each storage method has its own set of trade-offs between security, accessibility, maintainability, and usability.</span></p>
<p><span style="font-weight: 400;">Below, we break down the most common categories based on their associated level of perceived risk. </span><b></b></p>
<h3>Higher risk: “hot” wallets</h3>
<p><span style="font-weight: 400;">The concept doesn’t actually have much to do with temperature. When it comes to key storage options, a wallet is considered “hot” if it’s connected to the internet. A wallet is considered “cold,” on the other hand, if it’s offline and isolated. All else being equal, cold wallets are more secure than hot wallets – but they’re also more difficult to access and use. A wallet that is connected to any network is more susceptible to hacks as it allows attackers more chances for access to discover and exploit vulnerabilities.</span></p>
<p><span style="font-weight: 400;">Hot wallets can take a few forms.</span><i></i></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Connected software: online databases, phone or web server application memory, browser extensions</strong></li>
</ul>
<p><span style="font-weight: 400;">These are the riskiest options.</span> <span style="font-weight: 400;">Here, the wallet software, custodial or not, has direct access to the keys – all while being connected to the outside internet. The keys should ideally be encrypted, and the other set of keys used to encrypt them should be stored in a dedicated key management system (KMS) with highly restricted access controls such as an operating system keychain or a cloud key management system.</span></p>
<p><span style="font-weight: 400;">For software-based hot wallets, it is critical to isolate the key management and authorization from the rest of the software components. Problems can crop up in logging, error management, and memory management (especially heap-based, where keys may not be properly “zeroized,” or erased), all of which can mistakenly leak passwords, encryption keys, signing keys, or other sensitive cryptographic material. When that happens, interlopers can gain unauthorized access through connected applications or web servers, side channel attacks, or insider threats.</span></p>
<p><span style="font-weight: 400;">No matter how a service labels itself, if the signing keys are unencrypted at any time in the online system’s memory, then the model should be considered a hot software wallet. (Even if the keys are later stored at rest in a secure enclave.)</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Connected hardware: special-purpose devices, mobile secure enclaves, online hardware security modules (HSM)</strong></li>
</ul>
<p><span style="font-weight: 400;">Connected hardware is generally considered less risky than connected software, but it’s still not as secure as cold storage. In connected hardware, keys are generated and live only inside special-purpose hardware devices. These can then be connected either to internal or public networks. Such devices generally take on multiple responsibilities related to key management, including security for key generation, signing, and storage.</span></p>
<p><span style="font-weight: 400;">Connected hardware comes in several varieties. There are hardware wallets, such as Trezor and Ledger devices, which slightly more sophisticated crypto users commonly use. (Many more people should be using these devices, as they’re vastly safer than using connected software alone.) There are also hardware security modules, or HSMs, which are commonly used in more traditional business settings such as ones that handle sensitive data processing, like credit card payments.</span></p>
<p><span style="font-weight: 400;">Devices are only as safe as the supply chain that produced and configured them. When considering connected hardware, ask yourself: What’s the likelihood that either the devices – or firmware – were tampered with before coming into your possession? To reduce this risk, it’s best to buy devices directly from trusted vendors. Have them shipped directly from the source. Make sure the packages do not appear to be compromised – no rips, tears, broken seals, etc. – which might indicate tampering amid transport. It’s also advisable to verify the firmware version and configuration before use. The steps to do so vary depending on the hardware, but all should provide instructions.</span></p>
<p><span style="font-weight: 400;">Of course, there’s always the possibility that a hardware wallet could later be stolen or accessed by an unauthorized party. Given these threats, it’s important to make sure hardware wallets also have secure access control layers – safeguards ensuring they aren’t just blindly signing any and all transactions. Controls can include password requirements, prompts asking for explicit permission for every step of a transaction, and plain English summaries describing what transactions are actually doing. In addition, most hardware wallets support private key encryption, also known as “key wrapping.” Even better, secure wallets will not allow keys to be exported in raw plaintext form, even if one wished for them to be.</span></p>
<p><span style="font-weight: 400;">This is the level of safety that is required to truly safeguard crypto assets.</span></p>
<h3>Less risky: “cold” wallets</h3>
<p><span style="font-weight: 400;">Less heat, lower risk. Cold wallets are, all else being equal, generally considered more secure than hot ones, though they’re also generally less usable. Cold wallets are commonly called “airgapped” wallets, meaning they have no connection to any internal or public network.</span></p>
<p><span style="font-weight: 400;">Loneliness is a virtue in this case. Airgapping involves implementing rigorous physical isolation and authorization measures. These measures can include the use of Faraday cages (shields that block wireless signals), biometrics access (like fingerprint or iris scanners), motion sensors (to trip alarms in case of unauthorized use), and SCIFs, or Sensitive Compartmented Information Facilities (special areas for processing classified information).</span></p>
<p><span style="font-weight: 400;">Let’s review some cold wallet options in more detail.</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Airgrapped software: offline server application</strong></li>
</ul>
<p><span style="font-weight: 400;">Because an attacker can steal or take a machine online at any time, cold wallets should be designed with security systems that hold up even if they are brought online. Keys should be split in key shards – requiring the pieces to be rejoined to be made usable – through a standard method, such as Shamir’s Secret Sharing or Multi-Party Computation. Special purpose hardware, such as HSMs, are highly recommended over connected software as they generally offer more controls.</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Airgrapped hardware: offline hardware wallet, offline hardware security module (HSM)</strong></li>
</ul>
<p><span style="font-weight: 400;">This solution is considered the safest of all. Similar to the previous category, one should assume the hardware can be stolen and taken online. For that reason, it’s important again for these systems to include properly implemented access control layers, as discussed earlier. Many HSM vendors require a quorum of physical smartcards to come together before access to keys can be unlocked. Even if the device does not have a display screen, it should offer some way for users to verify the details of transactions.</span></p>
<p><span style="font-weight: 400;">Because cold or airgapped wallets are the safest category, most funds managed by big players are stored in this manner. Major retail services, such as Coinbase, Gemini, Kraken, and others, as well as services for institutional users such as Anchorage, are among those that do so. Many of these players choose to have another line of defense in the form of backups and recovery, just in case – heaven forbid – they lose access, or machines are corrupted, stolen, or destroyed.</span></p>
<h3>Backups and recovery</h3>
<p><span style="font-weight: 400;">Signing keys should always be backed up after being encrypted. It is critical to have redundancy of both encrypted signing keys and key-wrapping keys. Methods to back up a signing key differ, but one should always prefer hardware native solutions.</span></p>
<p><span style="font-weight: 400;">For hardware wallets, backups usually involve a 12-word plaintext seed phrase from which private keys are derived. This seed phrase should be stored non-digitally (think paper, metal) and in the most secure way available (a physical vault at home, inside a bank vault). The phrase can be split into parts that are geographically distributed to prevent easy compromise of the entire secret. (People sometimes explain this approach by referencing the fictional horcruxes which dark wizards use effectively to “backup” their souls in </span><i><span style="font-weight: 400;">Harry Potter</span></i><span style="font-weight: 400;">.)</span></p>
<p><span style="font-weight: 400;">Many HSMs natively handle some of the challenges related to backup and recovery. Standard ones have mechanisms that can export keys that are, by default, encrypted with access controls. If the access controls are satisfied, keys can then be imported into other HSMs. Usefully, fleets of HSMs can also be provisioned with a common encryption key, derived from a quorum of smartcards. Decoupling the hardware from the key materials in this manner helps avoid single points of failure.</span></p>
<p><span style="font-weight: 400;">Finally, human factors need addressing. Recovery mechanisms should be able to withstand the temporary or permanent unavailability of any individual involved in account management operations. Individuals should make sure to provide ways for close family members or other trusted parties to recover keys in case of death or other emergencies. Group operations, meanwhile, should define a quorum – such as 2-out-of-3 or 3-out-of-5, say – that can reasonably operate despite life events, travel, illness, or accidents.</span></p>
<h2 id="key-usage"><span style="font-weight: 400;">Key usage: wallet security</span></h2>
<p><span style="font-weight: 400;">After keys are generated and stored, they can be used to create digital signatures that authorize transactions. The more software and hardware components in the mix, the greater the risk. To reduce risk, wallets should abide by the following guidelines for authorization and authentication.</span><b></b></p>
<ul>
<li aria-level="1"><b>Trust, but verify</b></li>
</ul>
<p><span style="font-weight: 400;">Wallets should require authentication. In other words, they should verify that users are who they say they are, and that only authorized parties can access the wallet’s contents. The most common safeguards here are PIN codes or passphrases. As always, these should be sufficiently long and complex – using many different types of characters – to be maximally effective. More advanced forms of authentication can include biometrics or public key encryption-based approvals, such as cryptographic signatures from multiple other secured devices.</span><b></b></p>
<ul>
<li aria-level="1"><b>Don’t roll your own crypto (again!)</b></li>
</ul>
<p><span style="font-weight: 400;">Wallets should use well-established cryptography libraries. Do some research to ensure they’re audited and safe so as to avoid key material leakage or complete loss of private keys. Complicating the matter, even trusted libraries can have unsafe interfaces, as was recently the case with </span><a href="https://github.com/MystenLabs/ed25519-unsafe-libs" target="_blank" rel="noopener"><span style="font-weight: 400;">these Ed25519 libraries</span></a><span style="font-weight: 400;">. Be careful! </span><b></b></p>
<ul>
<li aria-level="1"><b>Nonce reuse</b></li>
</ul>
<p><span style="font-weight: 400;">A well-studied key usage pitfall is the inadvertent reuse of certain cryptographic signature parameters. Some signature schemes may require a </span><i><span style="font-weight: 400;">nonce</span></i><span style="font-weight: 400;"> meaning, “number used once,” an arbitrary number only meant to be used, well, once in a system. Elliptic Curve Digital Signature Algorithm (ECDSA) is one such signature scheme that does so. If a nonce is reused with ECDSA, it can lead to key compromise. Various other algorithms are not affected so, as usual, make sure well-established cryptographic libraries are being used. (Certain cryptographic libraries ensure unique nonces by hashing transaction data, which include other unique data such as account nonces.) But this attack vector has been exploited before in high-profile hacks outside of web3, such as this 2010 </span><a href="https://www.engadget.com/2010-12-29-hackers-obtain-ps3-private-cryptography-key-due-to-epic-programm.html" target="_blank" rel="noopener"><span style="font-weight: 400;">Sony PlayStation 3 hack</span></a><span style="font-weight: 400;">.</span><b></b></p>
<ul>
<li aria-level="1"><b>One key per purpose</b></li>
</ul>
<p><span style="font-weight: 400;">Another best practice is avoiding reuse of a key for more than a single purpose. Separate keys should be kept for encryption and signing, for example. This follows the principle of “</span><a href="https://en.wikipedia.org/wiki/Principle_of_least_privilege" target="_blank" rel="noopener"><span style="font-weight: 400;">least privilege</span></a><span style="font-weight: 400;">” in case of compromise, meaning that access to any asset, information, or operation should be restricted only to the parties or code that absolutely require it for the system to work. The principle of “least privilege” can, when properly implemented, drastically limit the blast radius of a successful attack. Different keys will have different requirements for backups and access management depending on their purpose. In the context of web3, it is a best practice to separate keys and seed phrases between assets and wallets, so compromise of one account does not affect any other.</span></p>
<h2><span style="font-weight: 400;">Conclusion</span></h2>
<p><span style="font-weight: 400;">The custodial or non-custodial nature of key ownership is not so black and white as conventional thinking would have one believe. The situation is complicated by the many moving parts involved in key management – from key generation to storage to usage. Every piece of hardware or software along the chain introduces risks that expose even supposedly non-custodial wallet options to custodial-type hazards. </span></p>
<p><span style="font-weight: 400;">For the future, we expect more development work to be done to secure wallets against attacks and to mitigate the risks discussed above. Areas of improvement include:</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Shared secure open-source key management and transaction signing libraries across mobile and desktop operating systems</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Shared open-source transaction approval frameworks</span></li>
</ul>
<p><span style="font-weight: 400;">Specifically, we would be particularly excited to see development for shared and open-source:</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Key generation libraries to implement best-in-class security across different storage backends (encrypted on disk, secure hardware, etc.)</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Key management and transaction signing libraries for mobile and desktop operating systems</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Frameworks for transaction approval flows implementing strong factor verification such as biometrics, PKI-based approvals, authorization recovery, etc.</span></li>
</ul>
<p><span style="font-weight: 400;">The above list is non-exhaustive, but it’s a good starting point. All this is to say, the situation is more complicated than the slogan “not your keys, not your crypto” indicates. Key possession is a tricky matter given the many interacting parts and phases from generation and storage through usage. </span></p>
<p><span style="font-weight: 400;">If you’re already working on a project that addresses any of the above, or would be interested in doing so, please reach out! We look forward to more progress on these fronts.</span></p>
<p><span style="font-weight: 400;">***</span></p>
<p><span style="font-weight: 400;">Editor: Robert Hackett, @rhhackett</span></p>
<p><span style="font-weight: 400;">***</span></p>
<p><i><span style="font-weight: 400;">The views expressed here are those of the individual AH Capital Management, L.L.C. (“a16z”) personnel quoted and are not the views of a16z or its affiliates. Certain information contained in here has been obtained from third-party sources, including from portfolio companies of funds managed by a16z. While taken from sources believed to be reliable, a16z has not independently verified such information and makes no representations about the current or enduring accuracy of the information or its appropriateness for a given situation. In addition, this content may include third-party advertisements; a16z has not reviewed such advertisements and does not endorse any advertising content contained therein.</span></i><i><span style="font-weight: 400;"> </span></i></p>
<p><i><span style="font-weight: 400;">This content is provided for informational purposes only, and should not be relied upon as legal, business, investment, or tax advice. You should consult your own advisers as to those matters. References to any securities or digital assets are for illustrative purposes only, and do not constitute an investment recommendation or offer to provide investment advisory services. Furthermore, this content is not directed at nor intended for use by any investors or prospective investors, and may not under any circumstances be relied upon when making a decision to invest in any fund managed by a16z. (An offering to invest in an a16z fund will be made only by the private placement memorandum, subscription agreement, and other relevant documentation of any such fund and should be read in their entirety.) Any investments or portfolio companies mentioned, referred to, or described are not representative of all investments in vehicles managed by a16z, and there can be no assurance that the investments will be profitable or that other investments made in the future will have similar characteristics or results. A list of investments made by funds managed by Andreessen Horowitz (excluding investments for which the issuer has not provided permission for a16z to disclose publicly as well as unannounced investments in publicly traded digital assets) is available at https://a16z.com/investments/.</span></i></p>
<p><i><span style="font-weight: 400;">Charts and graphs provided within are for informational purposes solely and should not be relied upon when making any investment decision. Past performance is not indicative of future results. The content speaks only as of the date indicated. Any projections, estimates, forecasts, targets, prospects, and/or opinions expressed in these materials are subject to change without notice and may differ or be contrary to opinions expressed by others. Please see https://a16z.com/disclosures for additional important information.</span></i></p>
                </div>
            </div>

            <div class="btn-hold">
                <a href="https://a16zcrypto.com" class="btn btn-outline">« back</a>
            </div>
        </div>
    </article>

    <div class="podcast">
        <div class="container">
            <div class="row row-height">
                <div class="col-md-6">
                    <iframe src="https://a16zcrypto.substack.com/embed" class="subscribe-iframe" frameborder="0" scrolling="no"></iframe>
                </div>
                <div class="col-md-6">
                    <div class="where-to-listen">
                        <div>
                            <img src="https://a16zcrypto.com/wp-content/uploads/2022/05/web3witha16z-copy-1-1024x1024.png" class="logo" alt="web3witha16z copy" />                                                            <h3>web3 with a16z</h3>
                                                        <p>a show about building the next internet, from a16z crypto (<a href="https://web3-with-a16z.simplecast.com/episodes/web3-with-a16z-a-show-about-the-next-internet-RBVtMkwX" target="_blank" rel="noopener">more</a>)</p>
                            								                                <ul class="podcast-platforms">
                                                                            <li><a href="https://podcasts.apple.com/us/podcast/web3-with-a16z/id1622312549" rel="noopener"><i class="icon-apple-podcasts"></i>Apple Podcasts</a></li>
                                                                            <li><a href="https://open.spotify.com/show/7pMZvsNXEnb0CYcPiDQywE" rel="noopener"><i class="icon-spotify"></i>Spotify</a></li>
                                                                            <li><a href="https://pca.st/4ghx22vk" rel="noopener"><i class="icon-pocket-casts"></i>Pocket Casts</a></li>
                                                                                                                <li>
                                            <div class="social-networks js-dropdown">
                                                <a href="#" class="link-drop">More</a>
                                                <ul>
                                                                                                            <li><a href="https://podcasts.google.com/feed/aHR0cHM6Ly9mZWVkcy5zaW1wbGVjYXN0LmNvbS9YUE9wSDdyNA" rel="noopener"><i class="icon-google-podcasts"></i>Google Podcasts</a></li>
                                                                                                            <li><a href="https://overcast.fm/p3764035-9zaUGP" rel="noopener"><i class="icon-overcast"></i>Overcast</a></li>
                                                                                                            <li><a href="https://www.iheart.com/podcast/1168-web3-with-a16z-96501686/" rel="noopener"><i class="icon-iheartradio"></i>iHeartRadio</a></li>
                                                                                                            <li><a href="https://www.stitcher.com/show/web3-with-a16z" rel="noopener"><i class="icon-stitcher"></i>Stitcher</a></li>
                                                                                                            <li><a href="https://music.amazon.com/podcasts/c8e9bb85-11da-4498-ac00-9288f493f6db/web3-with-a16z" rel="noopener"><i class="icon-amazon-music"></i>Amazon Music</a></li>
                                                                                                    </ul>
                                            </div>
                                        </li>
                                                                    </ul>
                                                    </div>
                    </div>
                </div>
            </div>
        </div>
    </div>

</main>

        <footer class="footer" id="footer">
    <div class="container">
        <div class="inner">
            <div class="nav-wrap">
                <div class="footer-nav"><ul id="menu-menu-1" class="menu"><li id="menu-item-86" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86"><a target="_blank" rel="noopener" href="https://a16z.com/disclosures/">disclosures</a></li>
<li id="menu-item-85" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-85"><a target="_blank" rel="noopener" href="https://a16z.com/tos-privacy/">terms of use &#038; privacy</a></li>
<li id="menu-item-84" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84"><a target="_blank" rel="noopener" href="https://a16z.com/briefings/">briefings</a></li>
<li id="menu-item-115" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115"><a target="_blank" rel="noopener" href="https://portfoliojobs.a16z.com/jobs?markets=FinTech+%26+Blockchain">jobs (in portfolio)</a></li>
<li id="menu-item-83" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83"><a target="_blank" rel="noopener" href="https://a16z.com/about/jobs/">jobs (with us)</a></li>
<li id="menu-item-88" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-88"><a target="_blank" rel="noopener" href="https://a16z.com/conduct/">conduct</a></li>
<li id="menu-item-82" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82"><a target="_blank" rel="noopener" href="https://a16z.com/about/contact/">contact</a></li>
</ul></div>            </div>
            <div class="footer-l">
                <div class="bottom-text">
                                        <span class="copyrights"><a href="https://a16z.com">&copy; 2022 Andreessen Horowitz</a></span>
                                        <ul class="social-networks">
                                                                    </ul>
                </div>
            </div>
        </div>
    </div>
</footer>

        <script type='text/javascript' src='https://a16zcrypto.com/wp-content/themes/a16z-crypto/assets/compiled/js/app.js?id=78b56c657f9eb8802223' id='base-theme-script-js'></script>
    </div>
</body>
</html>